David I has piracy issues...

Sunday, 28 October 2007 12:15 by salim

David I of CodeGear has written a blog lamenting about the amount of innovation is lost through software piracy. The thing I noticed was the familiarity of this argument with the one that is put forth by RIA. Then he brings in some statistics to prove that about 35% of software "value" is being lost through piracy...

CodeGear is in a rather dangerous downward spiral in their long term strategies, and capability to deliver. Even after four releases, their new Delphi IDE line is bogged with bugs and serious performance problems. Severe fragmentation of resources into several new projects (PHP, Ruby) have not helped them at all. Instead of trying to find out why CodeGear is becoming more and more of a developer antagonistic company these days.

Instead of drumming that old drum that the RIA has been beating for sometime. Open up, look around, basically grow up!!

Categories:  
Actions:   E-mail | del.icio.us | Permalink | Comments (1) | Comment RSSRSS comment feed

A Word About Mail Forwarding Etiquette

Monday, 22 October 2007 20:07 by salim

I am member of several mail groups, and have quite a few friends eager to show share some extremely informative or hilariously funny message with me.

I usually don't mind getting forwarded messages when the content is related to my primary interests or something relevant. But more often than not, these are pretty mundane, unfunny jokes and pseudo claims/information.

The worst offenders though are those mails with the forwarded message in attachment, often in a chain of attachments. So, if you want to read it, you have to open a series of attachment, and eventually you will find that obnoxious one line joke!!!

Anyone who forwards email to me, remember. If you don't have time to spend my reading experience better, DONT forward them to me...

Categories:  
Actions:   E-mail | del.icio.us | Permalink | Comments (0) | Comment RSSRSS comment feed

My Vista does everything wrong... they want me to go back to XP...

Monday, 15 October 2007 00:31 by salim

This is what Madam X (her own impersonation, I suggested Mrs.X) told us about what her computer tech told her.

Madam X is an artist, who has been using Windows XP for a while, and wanted to buy a new computer powerful enough to do serious graphic works. Mac was an option, but since both me and Shobha (my wife) are more familiar with Windows we suggested Vista. She went out and bought this pretty powerful Quad Core HP desktop with 3GB RAM and 1TB Hard Drive. Pretty impressive machine.

After a very brief honeymoon period, she started complaining about mysterious things happening. Sometimes, her computer did not allow her to open attachments of emails that she used to view without any trouble in XP. There was this mysterious problem of font settings never sticking in MS Word. There was other issues with creating labels, printing to her HP Laserjet, annoying popups, bizarre copy paste issues, etc. etc...

She had been complaining about this for a while, we first thought that it is just some teething troubles everybody feels when start using a totally new OS. However, her problems persisted and seemed to become worse by the day.

She had a regular computer tech who used to help her when she had issues before was reluctant to help her quoting his unfamiliarity with Vista. (A decent position I would say.. read on). So she called up the original seller Microcenter and complained about the issues. They told her to bring the machine in to see what can be done.

[The following is a paraphrasing, as we were not with her at Microcenter.]

She was first served by a technician who first did not believe her. He said that the problems are because she didn't know how to use Vista. However, once she started showing him the issues, he agreed. So the manager came in and did a higher level diagnostics. Again, after seeing the problems he was baffled as well. So he started telling her all the issues with Vista. He said that Vista is full of bugs and it will only be fixed when service pack I comes out. It is also possible, he said, that she might have gotten a particularly buggy version of Vista. (You know, like a lemon car). His recommendation was that she should consider going back to XP. Vista might not be the best OS for her, of course she will have to pay to put XP back in this machine. (This desktop is factory installed with Vista).

When Madam X emailed us that evening detailing her visit to Microcenter, we were a bit baffled as well. My wife started using Vista early this year. I had been testing Vista in a few virtual images and recently in my laptop. None of the issues she had been seeing were even remotely familiar to us. In both our cases Vista had been working rather smoothly, except for a Bluetooth driver issue in my machine and some early NVidia driver issues with Shobha's which had been since rectified. We invited Madam X and her computer for a lunch.

First problem, the computer has only DVI and we do not have any DVI monitors. (Yes I know, how sad...). Nor did we have an adapter. After some deliberations, I went out (reluctantly, come on it is a Sunday morning), first to a radioshack as I saw the thing in their website, and then to Staples. I came back and hooked up to our monitor, it booted fine.

The first thing I noticed was the number of things that popped up immediately on startup. There was this HP problem solver (or answer wizard or something) on top of the screen, which Madam X said did not answer any of her questions. Then there was this weird warning from some SuperSpy or something else Spyware program. Then there was a flashing screen of Symantec. Ok, first action - cleanup.

So I went to the startup programs and found some very interesting things there. First one ofcourse the SuperSpy thingie, which her Computer Tech installed promising absolute protection. Then there was an HP Toner Order Reminder (Sic), the answer wizard of course, and a couple of other quasi adware programs. We unselected all and restarted. Better, we can see the desktop now.

First Problem - Word does not obey default font settings

She uses MS Word 2003 for all her documents She does not like Times new roman (neither do I) and wanted all her documents to be Ariel. In her XP machine, she could create any new document and it always opened with Ariel. In Vista, she tried to change the font, but every time she opened a new document, the font went back to Times New roman. By the way this was the clinching issue for the Microcenter guy. (He called it totally bizzare and unexplainable)

Remedy, modify your default template (normal.dot). She must have done this when she first started using Word in her XP machine. But time is such a funny phenomenon that filters out only the crucial part of our experiences!!! So I started looking for normal.dot. Strangely enough it did not come up in my search, so Shobha started looking for it and within a second told me to look in Users/MadamX/Appdata/Roaming/Microsoft/Templates. Of course, there it was. So I opened it, changed the normal tag from Times new roman to Ariel, saved it back. We created several new documents and made sure that it is always Ariel. So, the first baffling bug in Vista is resolved.

While this was not too hard to find out for me and Shobha, there were a few things that were not very intuitive in these operations. For example, I would think that word should be smart enough to recognize the user behavior of changing the normal font to Ariel every time a new document is created. Second, I was unable to find a way to save the default template changes back. I am certain that i was able to do this without much effort earlier. Finding it in a hidden folder is not the easiest of things.

Second Problem - E-mail attachments that used to open are now cannot be opened.

One of her mailing groups used to send news letters that had extension of the month number to it. These were word documents, but, may be because it was saved from Mac did not have an MS word registered extension. So, when she tried to open this file, as usual the dialog came up warning her about the danger of opening this unrecognized file (with a lot of binary data ofcourse). When she said to go ahead, it showed the second dialog asking her to select a program to open it or look in the net to find a program. She selected to pick one from the list.. Boom, a dialog with a lot of red comes up telling her that windows cannot open this dangerous file.

Ok, this is frustrating. If Windows Mail knew about this file being a suspicious one and prevent her from opening it at the end, why did even go through the other two steps!!! Anyway, we told her that when she gets these kinds of files, that does not have a word icon to it, save it to the local folder and then open it from there. And this is not a good advice. The protection one gets from within Windows Mail against malicious files is not available from the explorer. But in this case, the sender is a trusted source. Once it is saved, one can follow the traditional way of picking a program to open the file, which in this case is MS Word. Once again, a bit un-intuitive that it first gave the user an impression that this process can eventually succeeded, eventhough Widows Mail could figure out that it is not the case. The messages were a bit too cryptic as well.

Third Problem - When a new mergemail document is created and gave the address in the first dialog box, print it does not do anything...

She showed me this, and yes, it does not (apparently) do anything. We repeated the step a couple of times, until we found out that if we want to see the new document, we need to press the New Document button after entering the data. Well, this time, it is equally a user error. The UI could give more information about the possibilities, but the help was very comprehensive. So I cant put the blame on Microsoft.

Fourth Problem - After creating a new label document, you cannot copy selected text. When you do a highlight, right click copy and paste operation, data previously copied was getting pasted. Whatever she does, the it never copies the intended text. In this case, we actually found that she was right clicking outside the selection, which in turn was unselecting the already selected text. Interestingly enough the Copy menu was still enabled. However, when you move to the next cell and right click paste, nothing happened. (We did not have a previous Clipboard content).

Shobha took over from me and gave a thorough lesson in copying and pasting and various tricks and tips. Thus that problem solved.

There remained other mysterious problems about backup (the desktop shortcut of backup turned out to be an XCopy batch file) and something else.

We finished the session by removing several programs including the SuperSpy ware and toner reminder (can you be more blatant!!!) and some other unused programs, set up windows backup to her removable hard drive etc.

Well, everything is fine for about 12 hours now. I am sure she will find other unfamiliar areas as she explore more and more. I am also sure that she is going to teach a thing or two to the expert who tells her that it is all because Vista is buggy, and she needs to go back to XP.

We, on our part, once again will be rewarded in hell for helping the Evil Microsoft Empire!!!!!

Tags:   ,
Categories:   Secret Garden
Actions:   E-mail | del.icio.us | Permalink | Comments (0) | Comment RSSRSS comment feed